Advanced search
Log In
New Account
  
Home My Page Project Cloud Code Snippets Project Openings Nibbles
Summary Forums Tracker News SCM Files Wiki

Bugs: Browse | Download .csv

[#2183] install fails on my n810

Please login

State:
Open
Date:
2008-02-16 13:44
Priority:
3
Submitted By:
Ron Ellenbecker (rone)
Assigned To:
Mark Somerville (spakman)
Summary:
install fails on my n810

Detailed description
here is thee log from the install.  it shows the app installed even though the install failed. I can uninstall app.

hildon-application-manager 2.0.1
[ Some installed packages are broken! ]
apt-worker: Not handling unrelated package lynx.
apt-worker: Not handling unrelated package ruby1.8-sqlite3.
apt-worker: Not handling unrelated package ruby1.8-maemo.
-----
Installing nibbles 0.0.4-1
apt-worker: Not handling unrelated package lynx.
apt-worker: Not handling unrelated package ruby1.8-sqlite3.
apt-worker: Not handling unrelated package ruby1.8-maemo.
apt-worker: Not handling unrelated package lynx.
apt-worker: Not handling unrelated package ruby1.8-sqlite3.
apt-worker: Not handling unrelated package ruby1.8-maemo.
Selecting previously deselected package ruby.
(Reading database ... 21327 files and directories currently installed.)
Unpacking ruby (from .../ruby_1.8.6_armel.deb) ...
Selecting previously deselected package libgems-ruby1.8.
Unpacking libgems-ruby1.8 (from .../libgems-ruby1.8_0.9.4-4_all.deb) ...
Selecting previously deselected package rubygems.
Unpacking rubygems (from .../rubygems_0.9.4-4_all.deb) ...
Selecting previously deselected package rubygems-hpricot.
Unpacking rubygems-hpricot (from .../rubygems-hpricot_0.6-1_armel.deb) ...
Selecting previously deselected package rubygems-simple-rss.
Unpacking rubygems-simple-rss (from .../rubygems-simple-rss_1.1-1_armel.deb) ...
Selecting previously deselected package rubygems-rubyforge.
Unpacking rubygems-rubyforge (from .../rubygems-rubyforge_0.4.0-1_armel.deb) ...
Selecting previously deselected package rubygems-rake.
Unpacking rubygems-rake (from .../rubygems-rake_0.8.1-1_armel.deb) ...
Selecting previously deselected package rubygems-hoe.
Unpacking rubygems-hoe (from .../rubygems-hoe_1.4.0-1_armel.deb) ...
Selecting previously deselected package rubygems-feed-normalizer.
Unpacking rubygems-feed-normalizer (from .../rubygems-feed-normalizer_1.4.0-1_armel.deb) ...
Selecting previously deselected package rubygems-atom.
Unpacking rubygems-atom (from .../rubygems-atom_0.3-1_armel.deb) ...
Selecting previously deselected package nibbles.
Unpacking nibbles (from .../nibbles_0.0.4-1_armel.deb) ...
Setting up ruby (1.8.6) ...
Setting up libgems-ruby1.8 (0.9.4-4) ...
Setting up rubygems (0.9.4-4) ...
Setting up rubygems-hpricot (0.6-1) ...
Setting up rubygems-simple-rss (1.1-1) ...
Setting up rubygems-rubyforge (0.4.0-1) ...
Setting up rubygems-rake (0.8.1-1) ...
Setting up rubygems-hoe (1.4.0-1) ...
Setting up rubygems-feed-normalizer (1.4.0-1) ...
Setting up rubygems-atom (0.3-1) ...
dpkg: dependency problems prevent configuration of nibbles:
 nibbles depends on ruby1.8-sqlite3; however:
  Package ruby1.8-sqlite3 is not configured yet.
 nibbles depends on ruby1.8-maemo (>= 0.3.0); however:
  Package ruby1.8-maemo is not configured yet.
 nibbles depends on lynx; however:
  Package lynx is not configured yet.
dpkg: error processing nibbles (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 nibbles
E: Sub-process /usr/bin/dpkg returned an error code (1)

Followup

Message
Date: 2008-02-21 15:19
Sender: Ron Ellenbecker

I reflashed my n810 to the just released firmware and nibbles
installed without error.  I did nothing special to get it
installed.
Date: 2008-02-19 09:52
Sender: Mark Somerville

I'm going to (a little reluctantly) close this, since I suspect
it's a problem with other packages.

If anyone else experiences this issue, please re-open the bug.
Date: 2008-02-18 16:08
Sender: Mark Somerville

Good - I'm glad you've got it working. I'm a little reluctant
to mark this as fixed just now though, since it shouldn't have
needed the intervention at all.

Can you explain what you mean by "download pictures",
please? Do you mean save them locally? Or display them within
Nibbles?
Date: 2008-02-17 01:57
Sender: Ron Ellenbecker

I uninstalled lynx and the.ruby packages.  I then installed lynx
and then the ruby packes.  Ithen installed nibblies.  It installed
correctly.  I saw the release notes this and all.  It runs, I
even added a feed.  Once you get outstanding issue like purging
ggoing I can take it for a real spin.

Affter a very quick spin some features I would like to see. 
I am sure you probably have these already but just in case...

organize feeds into folders
download pictures
zoom/change font size
import/export feed lists (opml file)
change storage location for feeds and pics

Date: 2008-02-16 22:54
Sender: Mark Somerville

Hi Ron,

Running Nibbles from the command line and posting any errors
is very useful, cheers. There is also a (very) crude log stored
in /tmp/nibbles.error_log which occasionally contains something
useful.

It seems like Nibbles has installed correctly, but some of the
dependencies (ruby1.8-maemo, ruby1.8-sqlite3 and lynx) haven't.
I don't know why this has happened.

Are ruby1.8-maemo, ruby1.8-sqlite3 and lynx shown as installed
in the Application Manager?

Here are some things to try:

* Remove and then try to install the dependencies individually
in the Application Manager

If that doesn't work:

* "dpkg --configure --pending" then "apt-get -f
install nibbles ruby1.8-maemo ruby-1.8 sqlite3 lynx" as
root (you may need to do it all a few times)

Failing that:

* Install the .debs for the broken dependencies manually (may
be better to download them and use "dpkg
-i <PACKAGE>.deb")

Good luck and thanks for your help in trying to get this
resolved.
Date: 2008-02-16 19:59
Sender: Ron Ellenbecker

Thanks for the uick response!  No need to rush it, don't want
you getting in trouble with your girlfriend.

nibbles shows as installed but failes to start

running nibbles from xterm gives message
loadError
no such file to load -- hildon
/usr/lib/ruby/site_ruby/1.8/nibbles/nibbles:32:in 'require'
/usr/lib/ruby/site_ruby/1.8/nibbles/nibbles:32

I checked and the files appear to exist

rubie and lynx are listed as installed

lynx from a terminal reports
error opening terminal:xterm.

I was not sure which debs to grab so I did not try that.


Date: 2008-02-16 18:36
Sender: Mark Somerville

The url for the .debs should be:

http://code.scottishclimbs.com/maemo/

I really shouldn't reply to bugs while shopping with my
girlfriend...
Date: 2008-02-16 16:52
Sender: Mark Somerville

Thanks for reporting this packaging bug.

After installing, are ruby1.8-maemo, ruby1.8-sqlite3and lynx
listed as being installed? If not, are able to install them through
the application manager? As a last try, how about installing
the .debs directly from http://code.scottishlimbs.com/maemo/ ?

Can you run the command "lynx"  from the terminal? 

Attached Files:

Name Download
No Files Currently Attached

Changes:

Field Old Value Date By
ResolutionNone2008-02-16 16:52spakman
assigned_tonone2008-02-16 16:52spakman

Terms of Use    Privacy Policy    Contribution Guidelines    Feedback

Powered By GForge Collaborative Development Environment