Advanced search
Log In
New Account
Home My Page Project Cloud Code Snippets Project Openings Pidgin On Maemo
Summary Forums Tracker Lists News SCM

Bugs: Browse | Download .csv

[#3586] icq changed protocol again

Please login

2009-03-10 10:30
Submitted By:
Yura Secret (zhiz0id)
Assigned To:
Nobody (None)
icq changed protocol again

Detailed description
2.5.1-2nix0 can't connect with icq protocol, errors.

look like 2.5.5 working fine.


Date: 2009-03-31 18:25
Sender: Marcel Heers

Thanks very much. This build is working for me just perfect.
I removed all old pidgin-files, downloaded
- libpurple0_2.5.5-0nix_armel
- pidgin_2.5.5-0nix_armel
- pidgin-emotes-default_2.5.5-0nix_all
- pidgin-l10n_2.5.5-0nix_all
- pidgin-sounds_2.5.5-0nix_all
and using "dpkg -i <pkg>" I installed them in
this order.
Date: 2009-03-31 02:51
Sender: Kai Engert

Looks I built it successfully, based on the original packages
(not using the workarounds proposed on this page).

You may find my build here, no guarantees given :-)
This is the first time I build anything for maemo or even debian

There is a .tar file that contains all the individual .deb

If you want to build yourself, after unpacking the source archive,
please delete file "configure".

With this binary, the ICQ protocol works for me.
I don't know how to build this into the usual installation
Date: 2009-03-16 21:05
Sender: Marcel Heers

Well, i don't know. I'm not that familar with debian-packaging,
but line 7 is an empty line, maybe dpkg needs to be in a special
version or needs an argument to ignore empty lines.
But for testing the following should work:

In the control-file ("/tmp/pidgin/DEBIAN/control" is
right) just paste the following lines and change it to your
Package: pidgin
Version: 2.5.5~nightsteam
Architecture: all
Maintainer: Marcel Heers <>
Installed-Size: 13025
Section: user/instantmessaging
Priority: optional
Description: Pidgin InstantMessenger

You also need a file named
"/tmp/pidgin/DEBIAN/debian-binary" with the only content
"2.0" (all without the breaks).

Hopefully this works.
Date: 2009-03-16 19:10
Sender: Kai Engert

> you can create the folder "/tmp/pidgin/"
> and install your compiled program to that folder with 
> "make DESTDIR=/tmp/pidgin install"

this worked

> Now move to /tmp/pidgin and create the control-files for
> deb-packaging

I tried to copy directory ./debian from the old source archive
to /tmp/pidgin but that resulted in "can not find

So I renamed /tmp/pidgin/debian to /tmp/pidgin/DEBIAN and tried

Now it complains 

> dpkg -b /tmp/pidgin pidgin-2.5.5-0nix0.deb
dpkg-deb: parse error, in file `/tmp/pidgin/DEBIAN/control' near
line 7:
 missing package name

... for the file that probably worked in the past???

Date: 2009-03-16 13:56
Sender: Marcel Heers

I tryied to build the old version (2.5.1) again but it failed:

autogenerating build system for 'Pidgin'
checking for autogen.args: not found.
checking for libtoolize...
checking for glib-gettextize... /usr/bin/glib-gettextize
checking for intltoolize... /usr/bin/intltoolize
checking for aclocal... /scratchbox/tools/bin/aclocal
checking for autoheader... /scratchbox/tools/bin/autoheader
checking for automake... /scratchbox/tools/bin/automake
checking for autoconf... /scratchbox/tools/bin/autoconf
running /targets/links/arch_tools/bin/libtoolize -c -f --automake...
running /usr/bin/glib-gettextize --force --copy... done.
Copying file mkinstalldirs
Copying file po/

Please add the files
  codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4
from the /usr/share/aclocal directory to your autoconf macro
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which you can
get from

running /usr/bin/intltoolize -c -f --automake... done.
running /scratchbox/tools/bin/aclocal -I m4macros... done.
/usr/share/aclocal/audiofile.m4:12: warning: underquoted definition
  run info '(automake)Extending aclocal'
  or see
running /scratchbox/tools/bin/autoheader ... done.
running /scratchbox/tools/bin/automake -a -c --gnu... failed. directory should not contain `/'
pidgin/pixmaps/ directory should not contain `/'

But if you have compiled the new version successfull, it won't
be that difficult to package it.

after compiling (hopefully you configured with "./configure
--prefix=/usr", because otherwise the plugins (n800 led)
won't work) you can create the folder "/tmp/pidgin/"
and install your compiled program to that folder with "make
DESTDIR=/tmp/pidgin install"
Now move to /tmp/pidgin and create the control-files for
And now a "dpkg -b /tmp/pidgin pidgin-2.5.5-0nix0.deb"
should do the job.
Date: 2009-03-16 00:01
Sender: Kai Engert

Sorry, my earlier tarball missed a lot of stuff.
A new attempt is here:

Meanwhile I set up a maemo build environment. I try to build
  dpkg-buildpackage -rfakeroot
but I fail with:

13	target: install 
14	dh_testdir 
15	dh_testroot 
16	dh_clean -k 
17	dh_installdirs 
18	dh_installdirs: dpkg-architecture failed 
19	make: *** [install-stamp] Error 1  
Date: 2009-03-12 05:58
Sender: Kai Engert


This is a diff between upstream original pidgin 2.5.1 and the
maemo source tarball:

And here is the diff between upstream original pidgin 2.5.5 and
my merged tarball:

You might use tkdiff to compare the diffs and verify I merged
Date: 2009-03-12 05:55
Sender: Kai Engert

Based on

and upstream pidgin-2.5.1 and upstream pidgin-2.5.5 I did a merge

I uploaded the resulting source archive here:

Maybe it saves you some time when trying a build?
Hopefully I merged correctly.

Unfortunately I don't have a maemo build environment at this
Date: 2009-03-10 13:38
Sender: Mark McNamee

Is someone working on a port of 2.5.5 for Maemo?

Attached Files:

Name Download
No Files Currently Attached


No Changes Have Been Made to This Item

Terms of Use    Privacy Policy    Contribution Guidelines    Feedback

Powered By GForge Collaborative Development Environment