Advanced search
Log In
New Account
  
Home My Page Project Cloud Code Snippets Project Openings ESbox
Summary Forums Tracker Lists Tasks News SCM Files Wiki

Bugs: Browse | Download .csv

[#4595] Multiple instances of vmware are started every time esbox wants to do something with the vm

Please login

State:
Open
Date:
2009-09-23 15:35
Priority:
3
Submitted By:
Axel Jäger (axeljaeger)
Assigned To:
Nobody (None)
Summary:
Multiple instances of vmware are started every time esbox wants to do something with the vm

Detailed description
I tried setup a development environment on a recent macbook. After starting the vm, I started esbox and  noticed that
after configuring the VM and clicking apply, a second instance of vmware was started. Obviously, it was not possible
to start the same VM twice.

I quit both instances of vmware and tried again starting esbox, this time with no vmware running. After my first changes
to the settings, vmware was started. After clicking a bit around, a second instance was started.

I never got the connection right, because esbox insisted on starting vmware. 

On macos, you never ever start two instances of program with a gui. Either use launch services to open the vm which
would use a running instance if available or ask the user to start the vm himself. Using your approach, it is not possible
to use vmware for other tasks.

Feel free to contact me if you have any questions. I have serious interest to get this working but I want it done right.
I'm willing to help doing it right.

Followup

Message
Date: 2009-10-16 13:48
Sender: Arto Hyvarinen

Verified with Esbox_build.542 in Mac OS 10.6.1 (VMware Fusion
2.0.6).
Date: 2009-09-28 18:47
Sender: Ed Swartz

Fixed in ESbox rev 2238 and Mica rev 2948
Date: 2009-09-24 13:48
Sender: Ed Swartz

As for the shared folders:  I realize on re-reading the
<http://esbox.garage.maemo.org/2nd_edition/virtual_machines.ht
ml> page that it's not very clear how to set things up here
(note: it's a manual task to set up shares on the host, and you're
just telling ESbox what you've done).  Add comments to #4200,
please.
Date: 2009-09-24 13:27
Sender: Axel Jäger

I looked at https://garage.maemo.org/frs/?group_id=192&releas
e_id=2799 because it was the obvious place to look for files.

Anyway, I download your provided file and tried again. I had
sucess connecting to the virtual machine, although it failed
first because target SSH port was set to 0 instead of 22.

Now I get an error message a step further when it tries to connect
file sharing:

There is no such share available
  Output:
  
  Mounting /home/maemo/shared from //172.16.27.1/axeljaeger's
Public Folder...
  WARNING: CIFS mount option 'dmask' is deprecated. Use 'dir_mode'
instead.
  mount error 6 = No such device or address
  Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
  ERROR: Failed to mount
  Errors:
  
  Password: 


Shall I open a new ticket for this?
Date: 2009-09-24 12:39
Sender: Ed Swartz

I assume you were looking in the "integration drops"
section?  The 8/19 drops were deleted, so maybe your cache is
out of date?

https://garage.maemo.org/frs/download.php/6678/esbox_2.0.0-I20090
9231056-common.zip
https://garage.maemo.org/frs/download.php/6680/esbox_2.0.0-I20090
9231056-macosx.carbon.x86.zip
https://garage.maemo.org/frs/download.php/6682/esbox-repository.z
ip

---

As for zeroconf, it looks like it's not a good solution: we can
already predict the address pretty closely in host-only or NAT
networking modes.  Bridged networking is exactly the case where
we'd need it, but if it can find other machines on a LAN (and
they all report as hostname="maemo" due to using the
common VM image), that's not much better... you'll still have
to look at your local VM to verify the address.  Thanks for the
information though :)
Date: 2009-09-24 07:57
Sender: Axel Jäger

Where can I get the new release? The newest files I see are from
2009-08-19 19:58
Date: 2009-09-24 07:40
Sender: Axel Jäger

Regarding zeroconf: The dependencies are not so bad if you use
the apple implementation. You can directly include the sources
if the license permits it. It compiles on all supported operating
systems. If you use avahi, it will very likely only work on linux
with reasonable effort. Zeroconf advertisements are usually not
routed so if you advertise from the virtual machine, it will
only be shown on the host that is connected to the same network
if you use either NAT or host only networking. if you bridge,
everyone in the same subnet will see the virtual machine.

Regarding vmrun: I think vmware player is the only backend that
does not come with vmrun. On the other hand, it is the free product
that a lot of people will use. I will try your solution and see
whether it works for me. I would be interested in taking benefit
of the product I paid for (vmware fusion) but respect that you
need a solution also for people using the free product.
Date: 2009-09-23 18:27
Sender: Ed Swartz

Ok, I haven't taken any of those steps directly, but I did notice
that it's vmware-vmx which owns the VM at runtime.  I looked
into vmrun at one time, but it's not available in all the VMware
variants available on Windows, and I wanted to avoid OS-specific
code there.  That may be required after all, though.

The current build is uploaded to garage now if you want to test
it.  It doesn't solve these issues completely, but it should
be better at detecting a running VM and letting you prevent ESbox
from launching VMware when you don't want it to.

BTW, zeroconf had crossed my mind once or twice, but it introduces
new dependencies in the VM images and on the hosts.  And I wasn't
sure how well it would interact over a LAN (would it be possible
to distinguish your own bridged VM from someone else's?).
Date: 2009-09-23 16:54
Sender: Axel Jäger

Hi,
good to hear. Does this mean I can have a new build to test by
the end of the week?

I saw the comments but they were not so specific so I post some
ideas what I have in mind:

1) Do not interact with the application binary vmware. It is
just the gui. For every VM, a new instance of vmware-vmx
is started.

2) Instead use the scripting API provided in /Library/Application
Support/VMware Fusion.
vmrun ist probably what you want to use

3) Do discovery between the host machine and the build using
zero conf networking (Not a number one priority but its not so
hard and you will impress a lot of people)
Date: 2009-09-23 15:42
Sender: Ed Swartz

Hi, what good timing!  Our next integration release (today or
tomorrow) should fix this very issue.  I spent several days on
just the UI problems underlying this.

See ESbox #4009 and the comments to see if they are on the right
track.  The essential change is, ESbox always asks before launching
a VM now.

Note: I also noticed while fixing this that we weren't detecting
a running VMware correctly, which I think should address the
issue of launching multiple instances that you raise here.

Attached Files:

Name Download
No Files Currently Attached

Changes:

Field Old Value Date By
ResolutionFixed2009-10-16 13:48arhyvari
ResolutionAccepted as a Bug2009-09-28 18:47eswartz
ResolutionAwating Response2009-09-25 20:05eswartz
ResolutionNone2009-09-23 15:42eswartz

Terms of Use    Privacy Policy    Contribution Guidelines    Feedback

Powered By GForge Collaborative Development Environment