Advanced search
Log In
New Account
Home My Page Project Cloud Code Snippets Project Openings ESbox
Summary Forums Tracker Lists Tasks News SCM Files Wiki

Bugs: Browse | Download .csv

[#4689] Mozilla XPCOM failure in newer Linux [Starting esbox just shows a small empty window.]

Please login

2009-10-19 14:43
Submitted By:
Murray Cumming (murrayc)
Assigned To:
Ed Swartz (eswartz)
Mozilla XPCOM failure in newer Linux [Starting esbox just shows a small empty window.]

Detailed description
I installed esbox 2.0.0-I200910070010 by unzipping the -command and -linux files. But when I start esbox from the terminal,
after answering the initial question about the workspace path, I just see a small empty window with "Esbox"
in the title.

There is no other UI whatsoever and no output in the terminal. The window cannot be closed.

This is on Ubuntu Karmic.


Date: 2011-01-22 03:45
Sender: jay savalia

I faces the same problem, but i follow the step provided by "Dane
Leckey" and it solved.

Hartley thanks..............
Date: 2010-06-06 17:42
Sender: Dane Leckey

Thanks for the info I followed the post and did the following
and it worked on Ubuntu 10.04 Lucid x86_64


Yes, thanks, adding this line to the bottom of esbox.ini fixed

Date: 2009-12-08 08:16
Sender: Arto Hyvarinen

Verified with Esbox_build.629.
Date: 2009-12-02 17:43
Sender: Ed Swartz

I committed a change (Mica rev 3505) to allow xulrunner 1.9.1.
Could you retest?
Date: 2009-12-02 15:21
Sender: Ed Swartz

Ok, sorry I was so dense.  Can you verify that Ubuntu 9.10 uses
xulrunner 1.9.0, and thus needs the script, but Fedora now has
1.9.1?  Maybe 1.9.1 fixes the bug.
Date: 2009-12-02 15:13
Sender: Arto Hyvarinen

Esbox starts and works normally with both xulrunner versions.
If I want use 1.9 version, I need to change version check in file. Start fails with original script, if xulrunner
version 1.8 is not installed (tar unpacked to folder
Date: 2009-12-02 13:40
Sender: Ed Swartz

Hmm, well, you said:  "... and tries to start
esbox and fails (a small empty window)."  I thought this
was the "lack of difference" you saw.

If in both cases, ESbox starts normally, then that's good :)
The bug would be if you get exceptions when starting with an
empty workspace, or invoking Help > Welcome.  (The small empty
window is a result of Eclipse trying to issue the exception dialog
before the rest of the framework was initialized.)
Date: 2009-12-02 07:54
Sender: Arto Hyvarinen

Sorry if I was unclear, Esboxs start now without errors. I meant,
that don't see any difference in Esbox behavoiur compared to
using 1.9 version of xulrunner. Is there any feature in Esbox,
that works only with version 1.8.

$ ./ 
Using xulrunner: /usr/lib/xulrunner/xulrunner

$ /usr/lib/xulrunner/xulrunner -v
Mozilla XULRunner

$ xulrunner -v
Mozilla XULRunner - 20091105041559

Date: 2009-12-01 16:14
Sender: Ed Swartz

Does say that it found /usr/lib/xulrunner/xulrunner?
What's the version it shows?

Could you add the error log?

Date: 2009-12-01 15:09
Sender: Arto Hyvarinen

Ok, I unpacked xulrunner 1.8 tar file to /usr/lib/xulrunner/
folder and ran command "sudo /usr/lib/xulrunner/xulrunner
--register-global". Now Esbox starts with script.
But I don't see any difference compared to using 1.9 version
of xulrunner (modified file to accept 1.9 version).
Date: 2009-12-01 14:40
Sender: Ed Swartz

Ok, I think you need to install that xulrunner 1.8 tar file.
If it works as elsewhere, it will go into
/usr/lib/xulrunner/xulrunner.  I agree you shouldn't uninstall
the 1.9 version.
Date: 2009-12-01 14:36
Sender: Arto Hyvarinen

If xulrunner 1.8 is not installed displays "Note:
xulrunner 1.8 should be installed..." and tries to start
esbox and fails (a small empty window).

It is not possible to install xulrunner 1.8 with yum and I didn't
find RPM package for Fedora 11. Tar file can be downloaded from
mozilla site, but I am not sure howto install multiple xulrunner
versions to same host. It's not option to uninstall 1.9 version,
because there are so much dependencies.
Date: 2009-11-30 19:28
Sender: Ed Swartz

Could you provide more details?  

The intended result is, if you have no xulrunner 1.8, the script
will not let you proceed.  Were you able to find and install
a xulrunner 1.8 version?

The script is supposed to go through some candidate locations
for xulrunner and check each one's version.  If you install the
1.8 version, does the script find the wrong one or does it fail
to find any correct version?

Date: 2009-11-27 12:33
Sender: Arto Hyvarinen

In Ubuntu 9.10 and scripts works Ok, but
in Fedora 11 xulrunner version is xulrunner-1.9.1 and version
check in script fails.
Date: 2009-11-19 16:17
Sender: Ed Swartz

Hi, for x86_64 you'd need to use update sites, since this is
not an officially supported platform (you'll need to use a VM
to run the officially supported Scratchbox).

The is in the latest integration release.  The archive
you mention is two months old :)
Date: 2009-11-19 16:14
Sender: rzr

what about karmic x86_64 ?
it does not even show the splash screen ...

where to get ? it's not in :

Date: 2009-11-09 20:37
Sender: Ed Swartz

Fixed as of build 581 (Linux builds only).  If you are on a newer
Ubuntu, run "" instead of "esbox".
I think this should work fine when running on older Ubuntu or
other Linux distros as well.

(The same goes for Pluthon and "").

Date: 2009-11-09 13:44
Sender: Ed Swartz

This bug, and another having to do with GTK 2.16 behavior
dependencies, will be addressed by shipping new ""
and "" scripts in the product, which check
for and advise a 1.18 build of xulrunner and set
Date: 2009-10-19 15:28
Sender: Murray Cumming

Yes, thanks, adding this line to the bottom of esbox.ini fixed


Date: 2009-10-19 15:19
Sender: Ed Swartz

The Mozilla browser widget component doesn't load.  Probably
Eclipse 3.4.x is too old for Ubuntu Karmic.

It seems there might be a solution here:

Try adding the given line to "esbox.ini".  Does that

Date: 2009-10-19 15:11
Sender: Murray Cumming

Here is the .log file. It seems to show some exceptions.

I did have the openjdk-6-jre package installed (by default, I
think). I have just installed the sun-java-6-jdk package and
that fixed the same problem (small empty window) with regular
Eclipse Ganymede. Even removing openjdk-6-jre did not fix this
problem for esbox.

I do see the splash screen, but this disappears after the progress
bar has completed. The small empty window then appears at about
the same size and position.

Date: 2009-10-19 14:51
Sender: Ed Swartz

Hmm, this is odd.  There is a splash screen with this title (hope
it's not being squashed by your WM) but after a little while
during the first launch the window should come up.

After the requisite question about using a Sun or IBM JVM instead
of gcj, which won't work, I'm not sure what could be going on.

There should be a log file under the workspace path in .metadata/.log.
Could you attach that?

Attached Files:

Name Download
No Files Currently Attached


Field Old Value Date By
ResolutionFixed2009-12-08 08:16arhyvari
ResolutionAwating Response2009-12-02 17:43eswartz
ResolutionNone2009-11-30 19:28eswartz
summaryMozilla XPCOM failure in newer Ubuntu [Starting esbox just shows a small empty window.]2009-11-30 19:28eswartz
ResolutionFixed2009-11-27 12:33arhyvari
ResolutionAccepted as a Bug2009-11-09 20:37eswartz
assigned_tonone2009-11-09 20:37eswartz
ResolutionNone2009-11-09 13:44eswartz
SeverityNone2009-11-09 13:44eswartz
summaryStarting esbox just shows a small empty window.2009-10-19 15:19eswartz
File Added636: .log2009-10-19 15:11murrayc

Terms of Use    Privacy Policy    Contribution Guidelines    Feedback

Powered By GForge Collaborative Development Environment