Advanced search
Log In
New Account
  
Home My Page Project Cloud Code Snippets Project Openings maemo SDK+
Summary Forums Tracker Lists Tasks Docs News SCM Files

Bugs: Browse | Download .csv

[#4769] Command "maemo-sdk install binaries diablo4.1.2_armel" failed

Please login

State:
Open
Date:
2009-11-05 22:22
Priority:
3
Submitted By:
Axel Pauli (discus-axel)
Assigned To:
Nobody (None)
Summary:
Command "maemo-sdk install binaries diablo4.1.2_armel" failed

Detailed description
I tried to install Maemo SDK+ according to http://maemo-sdk.garage.maemo.org/install-ubuntu.html in XUbuntu 9.10.

-First I saw, that the supported systems in the automatic python installer did not support Ubuntu 9.10.

-So I have followed the manual instructions of the guide. At last I failed with the Nokia binary installation. After
starting command:

maemo-sdk install binaries diablo4.1.2_armel

I get the following output:

------------------------BEGIN OUTPUT---------------------------------------

Downloading the binaries installer...
Using direct Internet access...
--2009-11-05 23:13:30--  http://repository.maemo.org/sb2/rootstrap/binaries/sb2-maemo-sdk-nokia-binaries_diablo_4.1.2.sh
Auflösen des Hostnamen »repository.maemo.org«.... 195.50.164.208, 195.50.164.200
Verbindungsaufbau zu repository.maemo.org|195.50.164.208|:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 3602070 (3,4M) [text/x-sh]
In »sb2-maemo-sdk-nokia-binaries_diablo_4.1.2.sh« speichern.
....
2009-11-05 23:13:36 (709 KB/s) - »sb2-maemo-sdk-nokia-binaries_diablo_4.1.2.sh« gespeichert [3602070/3602070]

/tmp/sb2-maemo-sdk-nokia-binaries_diablo_4.1.2.sh: 70: maemo-rootstrap: not found
E: Invalid rootstrap name specified!
WARNING: Binary installer script returned with an error.
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package maemo-explicit
WARNING: Binary package installation returned an error.
Done.

------------------------END OUTPUT-----------------------------------------

Looking into script sb2-maemo-sdk-nokia-binaries_diablo_4.1.2.sh showed me, that the following command
"maemo-rootstrap" failed:

if ! __rootstrap_root="`maemo-rootstrap path $__rootstrap`"; then
        echo "E: Invalid rootstrap name specified!"
        exit 2
fi

There is no tool to find with name 'maemo-rootstrap' in my installation. Maybe it was not installed by the Maemo-Sdk
installation procedure?

Please give me a hint how to overcome this blocking situation.

regards Axel

Followup

Message
Date: 2009-12-10 16:21
Sender: rzr www.rzr.online.fr

Hi I also confirm this message :

  sudo maemo-sdk install binaries ${SBOX_TARGET}

  /tmp/sb2-maemo-sdk-nokia-binaries_diablo_4.1.2.sh: line 67:
maemo-rootstrap: command not found


It appeared before on 64 bits env :
http://talk.maemo.org/showthread.php?p=365289#post365289

But also on chrooted 32bit debian system

Attached Files:

Name Download
No Files Currently Attached

Changes:

No Changes Have Been Made to This Item


Terms of Use    Privacy Policy    Contribution Guidelines    Feedback

Powered By GForge Collaborative Development Environment