Advanced search
Log In
New Account
  
Home My Page Project Cloud Code Snippets Project Openings Mica: Maemo IDE Common Architecture
Summary Tracker Lists News SCM Files Wiki

Bugs: Browse | Download .csv

[#4772] CYGWIN_HOME variable does not work in Pluthon SBRSH launch in Windows

Please login

State:
Open
Date:
2009-11-06 10:42
Priority:
3
Submitted By:
Arto Hyvarinen (arhyvari)
Assigned To:
Ed Swartz (eswartz)
Summary:
CYGWIN_HOME variable does not work in Pluthon SBRSH launch in Windows

Detailed description
Set CYGWIN_HOME in the Pluthon > Window > Preferences > Maemo > Environment panel (e.g.
"C:\cygwin\bin").
Launch Pluthon application in Windows XP using SBRSH download method and you get error: 
	sbrsh.exe - Unable To Locate Component
	This application has failed to start because cygwin1.dll was not found.

6.11.2009 10:12:09: sbrsh:Device over SBRSH
.$ "C:/Program Files/PC-Connectivity/bin/sbrsh.exe" -c "C:/Documents and
Settings/arhyvari/.PluThon_hello_world.py-pythonhildonhelloworldMaemodeviceUSBSSH.sbrsh" --no-sandbox
-r 29999,29999,user -d /home/user/.mica/workspace/pythonhildonhelloworld/src run-standalone.sh /usr/bin/python2.5
/home/user/.mica/workspace/pythonhildonhelloworld/src/hello_world.py
	add/replace CYGWIN_HOME=C:\cygwin\bin
	add/replace DBUS_SESSION_BUS_ADDRESS=unix:path=/tmp/session_bus_socket
	add/replace DISPLAY=:0
	add/replace PYTHONPATH=/home/user/.mica/workspace/pythonhildonhelloworld/src/

6.11.2009 10:12:10: ssh://user@192.168.2.15:22 
.$ /bin/sh -c "for i in /proc/[0-9]* ; do cat $i/cmdline; echo; cat $i/stat;done"
	add/replace CYGWIN_HOME=C:\cygwin\bin
	add/replace encode=arguments

6.11.2009 10:12:14: ssh://user@192.168.2.15:22 
.$ /bin/sh -c "for i in /proc/[0-9]* ; do cat $i/cmdline; echo; cat $i/stat;done"
	add/replace CYGWIN_HOME=C:\cygwin\bin
	add/replace encode=arguments

If you set "C:\cygwin\bin" to PATH SBRSH works Ok. Installation of Cygwin or Host-Pc-Connectivity does not
update PATH.

Followup

Message
Date: 2009-11-11 08:11
Sender: Arto Hyvarinen

Verified with Pluthon_build.583
Date: 2009-11-08 23:38
Sender: Ed Swartz

This is fixed.
Date: 2009-11-06 21:06
Sender: Ed Swartz

Ok, it seems the issue was, we augmented "PATH" with
this info, but Windows only recognizes "Path".

So, the bug was not about using CYGWIN_HOME, per se, but just
that whatever value we added for Cygwin, it was not recognized.

Attached Files:

Name Download
No Files Currently Attached

Changes:

Field Old Value Date By
ResolutionFixed2009-11-11 08:11arhyvari
ResolutionAccepted As Bug2009-11-08 23:38eswartz
assigned_tonone2009-11-08 23:38eswartz
VersionNone2009-11-06 21:06eswartz
ResolutionNone2009-11-06 21:06eswartz
File Added654: cygwin1.dll was not found.PNG2009-11-06 10:42arhyvari

Terms of Use    Privacy Policy    Contribution Guidelines    Feedback

Powered By GForge Collaborative Development Environment